BaselineWatch
Desk

CVE-2023-2017

8.8 high SSVC exploitation: poc Modified

Server-side Template Injection (SSTI) in Shopware 6 (<= v6.4.20.0, v6.5.0.0-rc1 <= v6.5.0.0-rc4), affecting both shopware/core and shopware/platform GitHub repositories, allows remote attackers with access to a Twig environment without the Sandbox extension to bypass the validation checks in `Shopware\Core\Framework\Adapter\Twig\SecurityExtension` and call any arbitrary PHP function and thus execute arbitrary code/commands via usage of fully-qualified names, supplied as array of strings, when referencing callables. Users are advised to upgrade to v6.4.20.1 to resolve this issue. This is a bypass of CVE-2023-22731.

Fix

Patch, vendor advisory and mitigation references on NVD 6

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 8.8 · shopwareNVD modified 2026-10-24 13:10

Affected (CPE criteria) 4

  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc1:*:*:*:*:*:*
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc2:*:*:*:*:*:*
  • cpe:2.3:a:shopware:shopware:6.5.0.0:rc3:*:*:*:*:*:*

References 6