BaselineWatch
Desk

CVE-2023-31039

9.8 critical SSVC exploitation: none Modified

Security vulnerability in Apache bRPC <1.5.0 on all platforms allows attackers to execute arbitrary code via ServerOptions::pid_file. An attacker that can influence the ServerOptions pid_file parameter with which the bRPC server is started can execute arbitrary code with the permissions of the bRPC process. Solution: 1. upgrade to bRPC >= 1.5.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.5.0/ https://dist.apache.org/repos/dist/release/brpc/1.5.0/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2218 https://github.com/apache/brpc/pull/2218

Fix

Patch, vendor advisory and mitigation references on NVD 4

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 9.8 · apacheNVD modified 2026-10-24 13:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:brpc:*:*:*:*:*:*:*:*

References 4