GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/geoserver/geoserver/commit/dc9ff1c726dd73c884437a123b4ad72b19383c7d Patch
- https://github.com/geoserver/geoserver/security/advisories/GHSA-w66h-j855-qr72 Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.1 · geoserverNVD modified 2026-10-18 20:10
Affected (CPE criteria) 1
cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:*
References 4
- https://github.com/geoserver/geoserver/commit/dc9ff1c726dd73c884437a123b4ad72b19383c7d Patch
- https://github.com/geoserver/geoserver/pull/7406 Issue Tracking
- https://github.com/geoserver/geoserver/security/advisories/GHSA-w66h-j855-qr72 Vendor Advisory
- https://osgeo-org.atlassian.net/browse/GEOS-11297 Issue Tracking