Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
Fix
Public exploits 2
- dwisiswant0/CVE-2025-46817 PoC on GitHub
- slayerkkkk/CVE-2025-46817-PoC PoC on GitHub
Each line links to the index that lists it, never to exploit code. Exploit-DB's "verified" and a Metasploit rank of good or better count as verified; a PoC-in-GitHub entry is a repository's claim.
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/redis/redis/commit/fc9abc775e308374f667fdf3e723ef4b7eb0e3ca Patch
- https://github.com/redis/redis/security/advisories/GHSA-m8fj-85cg-7vhp Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 8.8 · redisNVD modified 2026-10-19 17:10
Affected (CPE criteria) 1
cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:*