Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/vercel/next.js/commit/9c9aaed5bb9338ef31b0517ccf0ab4414f2093d8 Patch
- https://github.com/vercel/next.js/security/advisories/GHSA-4342-x723-ch2f Vendor Advisory
- https://vercel.com/changelog/cve-2025-57822 Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 8.2 · vercelNVD modified 2026-10-18 21:10
Affected (CPE criteria) 1
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
References 3
- https://github.com/vercel/next.js/commit/9c9aaed5bb9338ef31b0517ccf0ab4414f2093d8 Patch
- https://github.com/vercel/next.js/security/advisories/GHSA-4342-x723-ch2f Vendor Advisory
- https://vercel.com/changelog/cve-2025-57822 Mitigation, Vendor Advisory