Dataease is an open-source data visualization and analysis platform. In versions up to and including 2.10.12, the Impala data source is vulnerable to remote code execution due to insufficient filtering in the getJdbc method of the io.dataease.datasource.type.Impala class. Attackers can construct malicious JDBC connection strings that exploit JNDI injection and trigger RMI deserialization, ultimately enabling remote command execution. The vulnerability can be exploited by editing the data source and providing a crafted JDBC connection string that references a remote configuration file, leading to RMI-based deserialization attacks. This issue has been patched in version 2.10.13. It is recommended to upgrade to the latest version. No known workarounds exist for affected versions.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/dataease/dataease/commit/8d04e92d44e1bac9284e9e64df5afd7f96d9373c Patch
- https://github.com/dataease/dataease/security/advisories/GHSA-mvwc-x8x9-46c3 Exploit, Vendor Advisory
- https://github.com/dataease/dataease/security/advisories/GHSA-mvwc-x8x9-46c3 Exploit, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 8.7 · dataeaseNVD modified 2026-10-19 17:10
Affected (CPE criteria) 1
cpe:2.3:a:dataease:dataease:*:*:*:*:*:*:*:*