In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/kwwsg2j85f1b75o0ht5zbr34d7h66788 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 4.7 · apacheNVD modified 2026-10-18 20:10
Affected (CPE criteria) 2
cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*cpe:2.3:a:apache:cloudstack:4.21.0.0:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/kwwsg2j85f1b75o0ht5zbr34d7h66788 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/11/27/2 Mailing List, Third Party Advisory