LibreNMS is a community-based GPL-licensed network monitoring system. LibreNMS <= 25.8.0 contains a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Transports management functionality. When an administrator creates a new Alert Transport, the value of the Transport name field is stored and later rendered in the Transports column of the Alert Rules page without proper input validation or output encoding. This leads to arbitrary JavaScript execution in the admin’s browser. This vulnerability is fixed in 25.10.0.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/librenms/librenms/commit/706a77085f4d5964f7de9444208ef707e1f79450 Patch
- https://github.com/librenms/librenms/security/advisories/GHSA-frc6-pwgr-c28w Exploit, Vendor Advisory
- https://github.com/librenms/librenms/security/advisories/GHSA-frc6-pwgr-c28w Exploit, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 4.8 · librenmsNVD modified 2026-10-19 17:10
Affected (CPE criteria) 1
cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*