Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981 Patch
- https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2 Patch
- https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j Patch, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · lfprojectsNVD modified 2026-10-18 18:10
Affected (CPE criteria) 1
cpe:2.3:a:lfprojects:apptainer:*:*:*:*:*:go:*:*
References 6
- https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981 Patch
- https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2 Patch
- https://github.com/apptainer/apptainer/pull/3226 Issue Tracking
- https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j Patch, Vendor Advisory
- https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm Not Applicable
- https://github.com/sylabs/singularity/security/advisories/GHSA-wwrx-w7c9-rf87 Not Applicable