A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 10
- StatusAwaiting Analysis → PublishedNVD modified 2026-10-21 03:56
- StatusPublished → Awaiting AnalysisNVD modified 2026-10-21 04:16
- StatusAwaiting Analysis → PublishedNVD modified 2026-10-20 19:24
- StatusPublished → Awaiting AnalysisNVD modified 2026-10-20 20:17
- CVSS9.1 (v4.0, CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X)NVD modified 2026-10-20 20:17
- StatusAwaiting Analysis → PublishedNVD modified 2026-10-20 18:09
- References+1 references (now 2)NVD modified 2026-10-20 19:35
- StatusPublished → Awaiting AnalysisNVD modified 2026-10-20 19:35
- StatusReceived → PublishedNVD modified 2026-10-20 13:45
- First seenunscoredNVD modified 2026-10-20 14:16
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.