Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.
Fix
Patch, vendor advisory and mitigation references on NVD 3
- https://github.com/backstage/backstage/commit/2d5d3e77d630455d6d48cfa8f31fd3c126fd6f29 Patch
- https://github.com/backstage/backstage/releases/tag/v1.54.1 Patch, Release Notes
- https://github.com/backstage/backstage/security/advisories/GHSA-r9ph-3637-55px Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 4
- Cpes+2 CPE criteria (now 2)NVD modified 2026-10-16 14:50
- StatusUndergoing Analysis → AnalyzedNVD modified 2026-10-16 14:50
- CVSS5.3 (v3.1, CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N) → 6.5 (v3.1, CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N)NVD modified 2026-10-16 14:50
- First seenCVSS 5.3NVD modified 2026-10-10 03:17
Affected (CPE criteria) 2
cpe:2.3:a:linuxfoundation:backstage\/plugin-kubernetes-backend:*:*:*:*:*:node.js:*:*cpe:2.3:a:linuxfoundation:backstage:*:*:*:*:*:*:*:*