A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 6.3NVD modified 2026-10-19 15:16
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.
References 8
- https://github.com/GlitterWare/Passy/
- https://github.com/GlitterWare/Passy/commit/3d48df7cce05e39fa4de1e42768492307f26882e
- https://github.com/GlitterWare/Passy/issues/210
- https://github.com/GlitterWare/Passy/releases/tag/v1.10.2
- https://vuldb.com/cve/CVE-2026-112105
- https://vuldb.com/submit/1013135
- https://vuldb.com/vuln/422055
- https://vuldb.com/vuln/422055/cti