XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder. Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1. XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenunscoredNVD modified 2026-10-31 23:49
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.
References 3
- https://www.cve.org/CVERecord?id=CVE-2026-111497 vendor-advisory, related
- https://github.com/google/brotli/releases/tag/v1.2.1 release-notes
- https://metacpan.org/release/SYBER/XS-libbrotli-1.2.1.0/changes release-notes