A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an authenticated user to cause service disruption by supplying a repository release notes configuration file containing deeply nested YAML. When release notes were generated, the configuration file was parsed without a nesting depth limit, causing excessive resource consumption that could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.18, 3.18.12, 3.19.9, 3.20.5, and 3.21.3. This vulnerability was reported via the GitHub Bug Bounty program.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 5.7NVD modified 2026-10-24 20:10
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.
References 5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.17.18
- https://docs.github.com/en/[email protected]/admin/release-notes#3.18.12
- https://docs.github.com/en/[email protected]/admin/release-notes#3.19.9
- https://docs.github.com/en/[email protected]/admin/release-notes#3.20.5
- https://docs.github.com/en/[email protected]/admin/release-notes#3.21.3