Improper control of code generation in Amazon @aws-amplify/codegen-ui-react before 2.20.6 might allow a remote authenticated user to execute arbitrary code in end-user browsers, developer machines, CI/CD environments, and server-side rendering contexts via crafted Studio component or theme schema values due to insufficient coverage and effectiveness of the input validation introduced for CVE-2025-4318. To remediate this issue, users should upgrade to version 2.20.6
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://aws.amazon.com/security/security-bulletins/2026-066-aws/ Vendor Advisory
- https://github.com/aws-amplify/amplify-codegen-ui/security/advisories/GHSA-74xx-rjgf-m69j Patch, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.4 · amazonNVD modified 2026-10-23 22:10
Affected (CPE criteria) 1
cpe:2.3:a:amazon:amplify_codegen_ui:*:*:*:*:*:node.js:*:*