zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
Fix
Patch, vendor advisory and mitigation references on NVD 1
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 1.7 · ruby-langNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:ruby-lang:zlib:*:*:*:*:*:ruby:*:*
References 2
- https://github.com/ruby/zlib/security/advisories/GHSA-g857-hhfv-j68w Vendor Advisory
- https://hackerone.com/reports/3467067 Permissions Required