BaselineWatch
Desk

CVE-2026-31908

9.1 critical exploit SSVC exploitation: none Analyzed

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Fix

Public exploits 1

Each line links to the index that lists it, never to exploit code. Exploit-DB's "verified" and a Metasploit rank of good or better count as verified; a PoC-in-GitHub entry is a repository's claim.

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 9.1 · apacheNVD modified 2026-10-26 21:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

References 2