Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/0pjs72l7qj83j3srw1l1toyj24bsgkds Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.5 · apacheNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/0pjs72l7qj83j3srw1l1toyj24bsgkds Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/04/14/1 Mailing List, Third Party Advisory