A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.1 · apacheNVD modified 2026-10-23 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apr-util:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/06/9 Mailing List, Third Party Advisory