Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/1nl9zqft0ksqlhlkd3j4obyjz1ghoyn7 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · apacheNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
References 1
- https://lists.apache.org/thread/1nl9zqft0ksqlhlkd3j4obyjz1ghoyn7 Mailing List, Vendor Advisory