CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948 Exploit, Vendor Advisory
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948 Exploit, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.0 · ci4-cms-erpNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:ci4-cms-erp:ci4ms:*:*:*:*:*:*:*:*
References 3
- https://github.com/ci4-cms-erp/ci4ms/releases/tag/0.31.0.0 Release Notes
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948 Exploit, Vendor Advisory
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948 Exploit, Vendor Advisory