ChurchCRM is an open-source church management system. Prior to 7.1.0, critical pre-authentication remote code execution vulnerability in ChurchCRM's setup wizard allows unauthenticated attackers to inject arbitrary PHP code during the initial installation process, leading to complete server compromise. The "$dbPassword" variable is not sanitized. This vulnerability exists due to an incomplete fix for CVE-2025-62521. This vulnerability is fixed in 7.1.0.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 10.0 · churchcrmNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:churchcrm:churchcrm:*:*:*:*:*:*:*:*
References 1
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-pm2v-ggh4-mp7p Third Party Advisory