BaselineWatch
Desk

CVE-2026-39998

5.8 medium SSVC exploitation: none Analyzed

Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Fix

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 5.8 · apacheNVD modified 2026-10-26 11:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

References 2