Authentication Bypass by Spoofing vulnerability in Apache APISIX. The attacker can completely bypass authentication capitalising on certain configurations of jwt-auth plugin. This issue affects Apache APISIX: from v2.2 through v3.16.0. Users are recommended to upgrade to version v3.17.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.0 · apacheNVD modified 2026-10-25 23:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/nfopt8cnxd3k0rs1oxtr7lzxrdw4mojq Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/5 Third Party Advisory