FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2d Patch
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6 Exploit, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 8.8 · fastgptNVD modified 2026-10-26 21:10
Affected (CPE criteria) 1
cpe:2.3:a:fastgpt:fastgpt:*:*:*:*:*:*:*:*
References 3
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2d Patch
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5 Product, Release Notes
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6 Exploit, Vendor Advisory