BaselineWatch
Desk

CVE-2026-42509

6.1 medium SSVC exploitation: none Modified

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Fix

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 6.1 · apacheNVD modified 2026-10-26 19:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:*

References 2