Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, multiple tool implementations directly import and invoke raw HTTP clients (node-fetch, axios) instead of using the secured wrapper. These tools include (1) OpenAPIToolkit/OpenAPIToolkit.ts, (2) WebScraperTool/WebScraperTool.ts, (3) MCP/core.ts, and (4) Arxiv/core.ts. This vulnerability is fixed in 3.1.0.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-qqvm-66q4-vf5c Exploit, Mitigation, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-qqvm-66q4-vf5c Exploit, Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · flowiseaiNVD modified 2026-10-26 18:10
Affected (CPE criteria) 1
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*
References 2
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-qqvm-66q4-vf5c Exploit, Mitigation, Vendor Advisory
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-qqvm-66q4-vf5c Exploit, Mitigation, Vendor Advisory