Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/xkshmps51b24yw0qckl5h5ddyv0x6qf9 Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 2.3 · apacheNVD modified 2026-10-26 11:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/xkshmps51b24yw0qckl5h5ddyv0x6qf9 Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/6 Third Party Advisory