BaselineWatch
Desk

CVE-2026-44087

5.3 medium SSVC exploitation: none Analyzed

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Fix

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 5.3 · apacheNVD modified 2026-10-26 11:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

References 2