OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.1 · opnsenseNVD modified 2026-10-26 14:10
Affected (CPE criteria) 1
cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*
References 2
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6 Exploit, Mitigation, Vendor Advisory