Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.1 · vercelNVD modified 2026-10-26 14:10
Affected (CPE criteria) 1
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
References 1
- https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h Mitigation, Vendor Advisory