Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://github.com/vercel/next.js/security/advisories/GHSA-ffhc-5mcf-pf4q Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 4.7 · vercelNVD modified 2026-10-26 14:10
Affected (CPE criteria) 1
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
References 1
- https://github.com/vercel/next.js/security/advisories/GHSA-ffhc-5mcf-pf4q Mitigation, Vendor Advisory