Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://github.com/peerigon/angular-expressions/security/advisories/GHSA-pw8r-6689-xvf4 Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.3 · peerigonNVD modified 2026-10-26 18:10
Affected (CPE criteria) 1
cpe:2.3:a:peerigon:angular-expressions:*:*:*:*:*:node.js:*:*