Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
Fix
Patch, vendor advisory and mitigation references on NVD 1
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.5 · vercelNVD modified 2026-10-26 14:10
Affected (CPE criteria) 1
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*
References 8
- https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6 Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:54435
- https://access.redhat.com/security/cve/CVE-2026-45109
- https://bugzilla.redhat.com/show_bug.cgi?id=2477190
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45109.json