Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 2
- https://github.com/apache/commons-configuration/pull/634 Issue Tracking, Patch
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · apacheNVD modified 2026-10-26 14:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:commons_configuration:*:*:*:*:*:*:*:*
References 3
- https://github.com/apache/commons-configuration/pull/634 Issue Tracking, Patch
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/14/5 Mailing List, Third Party Advisory