Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.
Fix
Public exploits 1
- oscerd/CVE-2026-46588 PoC on GitHub
Each line links to the index that lists it, never to exploit code. Exploit-DB's "verified" and a Metasploit rank of good or better count as verified; a PoC-in-GitHub entry is a repository's claim.
Patch, vendor advisory and mitigation references on NVD 1
- https://camel.apache.org/security/CVE-2026-46588.html Vendor Advisory, Patch
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 7.3 · apacheNVD modified 2026-10-25 15:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:camel:*:*:*:*:*:*:*:*
References 2
- https://camel.apache.org/security/CVE-2026-46588.html Vendor Advisory, Patch
- http://www.openwall.com/lists/oss-security/2026/07/06/16 Third Party Advisory