Incorrect Authorization vulnerability in Apache APISIX. An attacker can capitalise on authz-casdoor plugin under default configuration to authenticate themselves with credentials from a different source. This issue affects Apache APISIX: from 2.14.1 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/lk4q5o855cocc7zq5wh1zlctfmcq6f76 Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · apacheNVD modified 2026-10-26 11:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/lk4q5o855cocc7zq5wh1zlctfmcq6f76 Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/9 Third Party Advisory