TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://github.com/tinymce/tinymce/security/advisories/GHSA-q742-qvgc-gc2f Patch, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.4 · tinyNVD modified 2026-10-14 20:10
Affected (CPE criteria) 1
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*