A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This issue affects Apache JSPWiki: through 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/yvbdjnocw5qq3xkbjs9h77ghlg0bsw2c Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.5 · apacheNVD modified 2026-10-23 22:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/yvbdjnocw5qq3xkbjs9h77ghlg0bsw2c Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/30/18 Mailing List, Third Party Advisory