BaselineWatch
Desk

CVE-2026-49230

6.3 medium exploit SSVC exploitation: none Analyzed

Improper Validation of Integrity Check Value vulnerability in Apache APISIX. The jwe-decrypt plugin under default configuration is vulnerable to authentication bypass. This issue affects Apache APISIX: from 3.8.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Fix

Public exploits 1

Each line links to the index that lists it, never to exploit code. Exploit-DB's "verified" and a Metasploit rank of good or better count as verified; a PoC-in-GitHub entry is a repository's claim.

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 6.3 · apacheNVD modified 2026-10-25 23:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

References 2