Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/s1jd1vxm59p6ghx47xhmpjdk1cobo4hn Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 2.3 · apacheNVD modified 2026-10-26 11:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/s1jd1vxm59p6ghx47xhmpjdk1cobo4hn Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/13 Third Party Advisory