BaselineWatch
Desk

CVE-2026-49871

2.1 low SSVC exploitation: none Analyzed

Cross-Site Request Forgery (CSRF) vulnerability in the cas-auth plugin under default configurations. This defect allows a remote attacker that manages to send a victim to a webpage controlled by them can cause the victim's browser to become authenticated as a different identity. Actions the victim takes upstream are then attributed to attackers identity. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Fix

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 2.1 · apacheNVD modified 2026-10-26 11:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*

References 2