Improper Authentication vulnerability in Apache APISIX. When the cas-auth plugin is used in a route, an attacker can possibly authenticate itself with credentials from a different source. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/bzjpo60ygxo7kxdqf7vw3l5zw2lh6m5k Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 5.3 · apacheNVD modified 2026-10-26 11:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/bzjpo60ygxo7kxdqf7vw3l5zw2lh6m5k Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/19/15 Third Party Advisory