Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 8.1 · caddyserverNVD modified 2026-10-25 23:10
Affected (CPE criteria) 1
cpe:2.3:a:caddyserver:caddy:*:*:*:*:*:*:*:*
References 5
- https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g Exploit, Third Party Advisory
- https://access.redhat.com/security/cve/CVE-2026-52845
- https://bugzilla.redhat.com/show_bug.cgi?id=2491907
- https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g Exploit, Third Party Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52845.json