Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106 Mailing List, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.5 · apacheNVD modified 2026-10-25 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/g4p5sf45p3f9r011pwqs9r54yd64s106 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/06/29/24 Third Party Advisory