Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp Vendor Advisory, Mailing List
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.5 · apacheNVD modified 2026-10-25 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/dcjdcnnnww9hhdm016hr0l7hpw1bzjfp Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/29/25 Third Party Advisory