Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::NodeSet#[] (and its alias #slice) checked the requested index against the node set's bounds using a 32-bit-truncated copy of the index. A large negative index could pass the check and then be used at full width, reading outside the node set's storage. On CRuby this is an out-of-bounds read that typically crashes the process; on JRuby it is not memory-unsafe but returns an incorrect node. This vulnerability is fixed in 1.19.4.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-5prr-v3j2-97mh Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 6.3 · nokogiriNVD modified 2026-10-25 23:10
Affected (CPE criteria) 1
cpe:2.3:a:nokogiri:nokogiri:*:*:*:*:*:ruby:*:*
References 1
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-5prr-v3j2-97mh Mitigation, Vendor Advisory