Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Fix
Patch, vendor advisory and mitigation references on NVD 1
- https://lists.apache.org/thread/7w9746ootcxo0gvx26xjpw80l31f1qw7 Mitigation, Vendor Advisory
Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.
Change history 1
- First seenCVSS 9.1 · apacheNVD modified 2026-10-24 21:10
Affected (CPE criteria) 1
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*
References 2
- https://lists.apache.org/thread/7w9746ootcxo0gvx26xjpw80l31f1qw7 Mitigation, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/14/8 Mailing List, Third Party Advisory