BaselineWatch
Desk

CVE-2026-59655

7.5 high SSVC exploitation: none Analyzed

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's OAuth authentication plugin while listing OAuth providers. This issue affects Apache CloudStack: from 4.19.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Fix

Patch, vendor advisory and mitigation references on NVD 1

Every line above is quoted from NVD, CISA, Microsoft, the vendor's own advisory or DISA; nothing is generated.

Change history 1

  1. First seenCVSS 7.5 · apacheNVD modified 2026-10-16 15:10

Affected (CPE criteria) 1

  • cpe:2.3:a:apache:cloudstack:*:*:*:*:*:*:*:*

References 1