A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Fix
Nothing published yet: no patch, vendor advisory or mitigation reference on NVD, no vendor advisory in the News for this CVE, not in CISA's KEV, no fixed package version. BaselineWatch does not guess at one.
Change history 1
- First seenCVSS 5.1NVD modified 2026-10-26 21:10
Affected (CPE criteria) 0
NVD has not attached CPE configurations yet.
References 8
- https://github.com/1Panel-dev/MaxKB/
- https://github.com/1Panel-dev/MaxKB/commit/026a2d623e2aa5efa67c4834651e79d5d7cab1da
- https://github.com/1Panel-dev/MaxKB/pull/4919
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.8.0
- https://github.com/AnalogyC0de/public_exp/issues/24
- https://vuldb.com/submit/782263
- https://vuldb.com/vuln/356966
- https://vuldb.com/vuln/356966/cti